#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\$\$.*?)lo(.*?\$\$)"
Local $sString = "some random text $$ hello world $$ some more stuff"
Local $sSubst = "\15\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)