#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>"
Local $sString = "<span class="grey black-text lighten-2 credit-counter"><span class="remaining">2</span> credits</span>"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)