$re = '/.+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>/m';
$str = '<span class="grey black-text lighten-2 credit-counter"><span class="remaining">2</span> credits</span>';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;