import Foundation
let pattern = #".+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<span class="grey black-text lighten-2 credit-counter"><span class="remaining">2</span> credits</span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)