import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+?<span class=\"remaining\">([0-9]+)?<\\/span>(.+?)<\\/span>";
final String string = "<span class=\"grey black-text lighten-2 credit-counter\"><span class=\"remaining\">2</span> credits</span>";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}