using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?<span class=""remaining"">([0-9]+)?<\/span>(.+?)<\/span>";
string substitution = @"$1$2";
string input = @"<span class=""grey black-text lighten-2 credit-counter""><span class=""remaining"">2</span> credits</span>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}