const regex = /.+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?<span class="remaining">([0-9]+)?<\\\/span>(.+?)<\\\/span>', 'gm')
const str = `<span class="grey black-text lighten-2 credit-counter"><span class="remaining">2</span> credits</span>`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);