import re
regex = re.compile(r".+?<span class=\"remaining\">([0-9]+)?<\/span>(.+?)<\/span>", flags=re.MULTILINE)
test_str = "<span class=\"grey black-text lighten-2 credit-counter\"><span class=\"remaining\">2</span> credits</span>"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)