package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>`)
var str = `<span class="grey black-text lighten-2 credit-counter"><span class="remaining">2</span> credits</span>`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}