# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/TEXTBEFORE(.+?)TEXTAFTER/TextA$1TextB/g;t' <<< "TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER"