// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"TEXTBEFORE(.+?)TEXTAFTER").unwrap();
let string = "TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER";
let substitution = "TextA$1TextB";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}