use strict;
my $str = 'TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER';
my $regex = qr/TEXTBEFORE(.+?)TEXTAFTER/p;
my $subst = 'TextA$1TextB';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";