import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TEXTBEFORE(.+?)TEXTAFTER";
final String string = "TEXTBEFOREfoo_abcTEXTAFTER\n"
+ "TEXTBEFOREgoo_zxyTEXTAFTER\n"
+ "TEXTBEFOREdoo_fghTEXTAFTER";
final String subst = "TextA$1TextB";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}