$re = '/TEXTBEFORE(.+?)TEXTAFTER/';
$str = 'TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER';
$subst = "TextA$1TextB";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;