#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "TEXTBEFORE(.+?)TEXTAFTER"
Local $sString = "TEXTBEFOREfoo_abcTEXTAFTER" & @CRLF & _
"TEXTBEFOREgoo_zxyTEXTAFTER" & @CRLF & _
"TEXTBEFOREdoo_fghTEXTAFTER"
Local $sSubst = "TextA$1TextB"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)