import re
regex = re.compile(r"TEXTBEFORE(.+?)TEXTAFTER")
test_str = ("TEXTBEFOREfoo_abcTEXTAFTER\n"
"TEXTBEFOREgoo_zxyTEXTAFTER\n"
"TEXTBEFOREdoo_fghTEXTAFTER")
subst = "TextA$1TextB"
result = regex.sub(subst, test_str)
if result:
print(result)