re = /TEXTBEFORE(.+?)TEXTAFTER/
str = 'TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER'
subst = 'TextA$1TextB'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result