package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`TEXTBEFORE(.+?)TEXTAFTER`)
var str = `TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER`
var substitution = "TextA$1TextB"
fmt.Println(re.ReplaceAllString(str, substitution))
}