using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TEXTBEFORE(.+?)TEXTAFTER";
string substitution = @"TextA$1TextB";
string input = @"TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}