const regex = /TEXTBEFORE(.+?)TEXTAFTER/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('TEXTBEFORE(.+?)TEXTAFTER', 'g')
const str = `TEXTBEFOREfoo_abcTEXTAFTER
TEXTBEFOREgoo_zxyTEXTAFTER
TEXTBEFOREdoo_fghTEXTAFTER`;
const subst = `TextA$1TextB`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);