package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}`)
var str = `int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf("printf")
}
}`
var substitution = "${body}"
fmt.Println(re.ReplaceAllString(str, substitution))
}