const regex = new RegExp('[\\w ]+ main\\([\\w ]*\\){(?P<body>(?:\\n|.)+)}', 'g')
const str = `int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf("printf")
}
}`;
const subst = `${body}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);