import re
regex = re.compile(r"[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}")
test_str = ("int main(void){\n"
"//printf test //\n"
"a = 5\n"
"if a{\n"
" printf(a)\n"
"}\n"
" if a{\n"
"printf(\"printf\")\n"
"}\n"
"}")
subst = "${body}"
result = regex.sub(subst, test_str)
if result:
print(result)