$re = '/[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}/';
$str = 'int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf("printf")
}
}';
$subst = "${body}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;