import Foundation
let pattern = #"[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf("printf")
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${body}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)