use strict;
my $str = 'int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf("printf")
}
}';
my $regex = qr/[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}/p;
my $subst = '${body}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";