re = /[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}/
str = 'int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf("printf")
}
}'
subst = '${body}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result