// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}").unwrap();
let string = "int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf(\"printf\")
}
}";
let substitution = "${body}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}