import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w ]+ main\\([\\w ]*\\)\\{(?P<body>(?:\\n|.)+)\\}";
final String string = "int main(void){\n"
+ "//printf test //\n"
+ "a = 5\n"
+ "if a{\n"
+ " printf(a)\n"
+ "}\n"
+ " if a{\n"
+ "printf(\"printf\")\n"
+ "}\n"
+ "}";
final String subst = "${body}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}