# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Metodo di pagamento).*\n\x07.*/\0#end/mg;t' <<< "Metodo di pagamento selezionato:
Mastercard
"