// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Metodo di pagamento).*\n\x07.*").unwrap();
let string = "Metodo di pagamento selezionato:
Mastercard
";
let substitution = "\\0#end";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}