import Foundation
let pattern = #"(Metodo di pagamento).*\n\x07.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Metodo di pagamento selezionato:
Mastercard
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"\0#end"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)