#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(Metodo di pagamento).*\n\x07.*"
Local $sString = "Metodo di pagamento selezionato: " & @CRLF & _
"Mastercard " & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\0#end"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)