re = /(Metodo di pagamento).*\n\x07.*/m
str = 'Metodo di pagamento selezionato:
Mastercard
'
subst = '\\0#end'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result