const regex = /(Metodo di pagamento).*\n\x07.*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Metodo di pagamento).*\\n\\x07.*', 'mg')
const str = `Metodo di pagamento selezionato:
Mastercard
`;
const subst = `\0#end`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);