$re = '/(Metodo di pagamento).*\n\x07.*/m';
$str = 'Metodo di pagamento selezionato:
Mastercard
';
$subst = "\0#end";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;