package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Metodo di pagamento).*\n\x07.*`)
var str = `Metodo di pagamento selezionato:
Mastercard
`
var substitution = "\0#end"
fmt.Println(re.ReplaceAllString(str, substitution))
}