import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Metodo di pagamento).*\\n\\x07.*";
final String string = "Metodo di pagamento selezionato: \n"
+ "Mastercard \n"
+ "\n"
+ "";
final String subst = "\\0#end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}