use strict;
my $str = 'Metodo di pagamento selezionato:
Mastercard
';
my $regex = qr/(Metodo di pagamento).*\n\x07.*/mp;
my $subst = '\\0#end';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";