# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])/${name}\nrandomtext$2${name2}\nrandomtexts/gm;t' <<< " lastBid = 25
dfdfdfdf
lastBid = 3"