import Foundation
let pattern = #"(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
lastBid = 25
dfdfdfdf
lastBid = 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${name}\nrandomtext$2${name2}\nrandomtexts"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)