$re = '/(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])/m';
$str = ' lastBid = 25
dfdfdfdf
lastBid = 3';
$subst = "${name}\nrandomtext$2${name2}\nrandomtexts";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;