package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])`)
var str = ` lastBid = 25
dfdfdfdf
lastBid = 3`
var substitution = "${name}\nrandomtext$2${name2}\nrandomtexts"
fmt.Println(re.ReplaceAllString(str, substitution))
}