import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<name>lastBid = 2[0-5])([\\s\\S]*?)(?<name2>lastBid = [0-9])";
final String string = " lastBid = 25\n"
+ "dfdfdfdf\n"
+ " lastBid = 3";
final String subst = "${name}\\nrandomtext$2${name2}\\nrandomtexts";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}