use strict;
my $str = ' lastBid = 25
dfdfdfdf
lastBid = 3';
my $regex = qr/(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])/mp;
my $subst = '${name}\\nrandomtext$2${name2}\\nrandomtexts';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";