// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])").unwrap();
let string = " lastBid = 25
dfdfdfdf
lastBid = 3";
let substitution = "${name}\\nrandomtext$2${name2}\\nrandomtexts";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}