# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])"
test_str = (" lastBid = 25\n"
"dfdfdfdf\n"
" lastBid = 3")
subst = "${name}\\nrandomtext$2${name2}\\nrandomtexts"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.