#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])"
Local $sString = " lastBid = 25" & @CRLF & _
"dfdfdfdf" & @CRLF & _
" lastBid = 3"
Local $sSubst = "${name}\nrandomtext$2${name2}\nrandomtexts"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)