const regex = /(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>lastBid = 2[0-5])([\\s\\S]*?)(?<name2>lastBid = [0-9])', 'gm')
const str = ` lastBid = 25
dfdfdfdf
lastBid = 3`;
const subst = `${name}\nrandomtext$2${name2}\nrandomtexts`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);