using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>lastBid = 2[0-5])([\s\S]*?)(?<name2>lastBid = [0-9])";
string substitution = @"${name}\nrandomtext$2${name2}\nrandomtexts";
string input = @" lastBid = 25
dfdfdfdf
lastBid = 3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}